To properly view this site I suggest using
Netscape 3.0 Or Explorer 4.0 or better
  
You will also need the shockwave flash plug in.

If you are still having problems or have questions
please e-mail help@insho.com